忍者ブログ

ゲームやマンガなどなど

ゲームやマンガの紹介などなど

[PR]

×

[PR]上記の広告は3ヶ月以上新規記事投稿のないブログに表示されています。新しい記事を書く事で広告が消えます。

apache2.2とphp5.2.17のインストール

apacheとphpのインストールは4,5回やってるけんど間違えちゃうのでメモします

その前に、ディスクのクリーンアップとか、cccleanでdiskを少しきれいにしました
cccleanは、mysqlのレジストリィを削除するという前科がありましたので、いろいろ
インスートールする前に実行です

apacheのダウンロードは、ここからですよね

最新リリースの2.4.2は、windows binaryがなかったので、2.2.22の
Win32 Binary including OpenSSL 0.9.8tをダウンロードしました
(どっかでopensslがないとというのにひっかかった気がするので)

msiなのでそれを実行して、次へ次へと、インストールディクトリィはprogram fles
にすると権限がやっかいなので、apacheというディレクトリィを作ってそこに
インストール

とりあえず it worksがでてよしと

phpは、まず、ここへ いくと

で、ダウンロードのページにいって、Windows Binariesのページへ

すると、最新は、php5.4だけど、vc6(apache.dllがあるやつ)がない

下にいくと、php5.2.17でvc6があるので、これのThread Safeのやつでいいかと

ntsだとapacheをどう設定するのかわからなかった

msiなので次へ次へでインストールディクトリィだけ変えてインストール
したけど、extensionがインストールされない

もう一度やると、ディレクトリイの絵があるところで、ディレクトリィをクリックして
選択してあげないとエクステンションは、入らないのね
gdとmb_covertとか必要なので、とりあえず全部いんすとーる

httd.confは、とりあえず

PHPIniDir "C:\PHP"
LoadModule php5_module "C:\PHP\php5apache2_2.dll"
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

だけ追加

mime.typesに

application/x-httpd-php php
application/x-httpd-php-source phps

だけ追加

php.iniは、とりあえずエラーがでるように

display_errors = On
error_reporting  =  E_ALL & ~E_NOTICE

こんだけ、修正

apacheを再起動すると、あら動かないじゃん

phpをインストールしたとき、extensonをインストールすると
php.iniも書き換えてくれたけど、mysqlとか、sqlliteとかない
ものも追加されてしまったので、使うもの以外(gd2とmb_convert)は
コメントアウトしたら立ち上がった

エラーメッセージとかがどこにでるかもよくわからなくて、難儀
(windows tempなのか)

バージョンとかが微妙に違うので、毎回なんか失敗しちゃう

今、みたら最新のphp5.4をインストールしたければ、
apacheのvc9版を探してインストールすればいいらしいけど、
ま、これでいいか

php5.0系はなんかおかしい気もしたけど、5.2はいい感じがするし
PR

コメント

お名前
タイトル
文字色
メールアドレス
URL
コメント
パスワード Vodafone絵文字 i-mode絵文字 Ezweb絵文字

カレンダー

08 2017/09 10
S M T W T F S
1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30

PR

powerd by rAccessr for javascript



にほんブログ村 漫画ブログ コミックス感想へ
にほんブログ村

プロフィール

HN:
tele
性別:
非公開

バーコード

ブログ内検索

P R

忍者アナライズ